Cisco 路由器配置命令大全

Cisco 路由器配置命令大全

(1)模式转换命令

用户模式----特权模式,使用命令"enable" 特权模式----全局配置模式,使用命令"config t"

全局配置模式----接口模式,使用命令"interface+接口类型+接口号" 全局配置模式----线控模式,使用命令"line+接口类型+接口号"

注: 用户模式:查看初始化的信息.

特权模式:查看所有信息、调试、保存配置信息 全局模式:配置所有信息、针对整个路由器或交换机的所有接口 接口模式:针对某一个接口的配置 线控模式:对路由器进行控制的接口配置

(2)配置命令

show running config  显示所有的配置

show versin  显示版本号和寄存器值

show interface+接口类型+接口号 查看接口管理性 show controllers interface  查看接口是否有 DCE 电缆 show history  查看历史记录

show terminal  查看终端记录大小

show ip interface brief  查看接口的谪要信息

show spamming-tree vlan +vlan 号 查看 VLA 怕生成树议

shut down  关闭接口

no shutdown  打开接口

ip add +ip 地址 配置 IP 地址

secondary+IP 地址 为接口配置第二个 IP 地址 hostname+主机名 配置路由器或交换机的标识 config memory  修改保存在 NVRAM 中的启动配置 exec timeout 0 0  设置控制台会话超时为 0

service password-encryptin  手工加密所有密码

enable password +密码 配置明文密码

ena sec +密码 配置密文密码

line vty 0 4/15  进入 telnet 接口 password +密码 配置 telnet 密码 line aux 0  进入 AUX 接口 password +密码 配置密码

line con 0 进入 CON 接口 password +密码 配置密码 bandwidth+数字 配置带宽

no ip address  删除已配置的 IP 地址

show startup config  查看 NVRAM 中的配置信息 copy run-config atartup config  保存信息到 NVRAM write  保存信息到 NVRAM

 

erase startup-config  清除 NVRAM 中的配置信息

banner motd # +信息 + #  配置路由器或交换机的描素信息

description+信息 配置接口听描素信息 vlan database  进入 VLAN 数据库模式 vlan +vlan 号+  名称 创建 VLAN

switchport access vlan +vlan 号 为 VLAN 为配接口

interface vlan +vlan 号 进入 VLAN 接口模式

ip add +ip 地址 为 VLAN 配置管理 IP 地址 vtp+service/tracsparent/client  配置 SW 的 VTP 工作模式 vtp +domain+域名 配置 SW 的 VTP 域名

vtp +password +密码 配置 SW 的密码

switchport mode trunk  启用中继

no vlan +vlan 号 删除 VLAN

2.  路由器配置命令

ip route+非直连网段+子网掩码+下一跳地址 配置静态/默认路由

show ip route  查看路由表

show protocols  显示出所有的被动路由协议和接口上哪些协议被设置

show ip protocols  显示了被配置在路由器上的路由选择协议

show ip eigrp neighbors  查看邻居表 show ip eigrp topology  查看拓扑表 show ip eigrp traffic  查看发送包数量

show ip ospf  显示 OSPF 的进程号和 ROUTER-ID show user  查看 SW 的在线用户

router rip  激活 RIP 协议

network +直连网段 发布直连网段

interface lookback 0  激活逻辑接口

passive-interface +接口类型+接口号 配置接口为被动模式

debug ip +协议 动态查看路由更新信息 undebug all  关闭所有 DEBUG 信息 router eigrp +as 号 激活 EIGRP 路由协议 network +网段+子网掩码 发布直连网段 router ospf +process-ID  激活 OSPF 协议

network+直连网段+area+区域号 发布直连网段

encapsulation+封装格式 更改封装格式

no ip admain-lookup  关闭路由器的域名查找 ip routing  在三层交换机上启用路由功能 clear line +线路号 清除线路

3.  三层交换机配置命令 配置一组二层端口

configure terminal  进入配置状态

nterface range {port-range}  进入组配置状态

 

配置三层端口

configure terminal  进入配置状态

interface {{fastethernet | gigabitethernet} interface-id} | {vlan vlan-id} | {port-

channel port-channel-number}  进入端口配置状态

no switchport  把物理端口变成三层口

ip address ip_address subnet_mask  配置 IP 地址和掩码

no shutdown  激活端口 例:

Switch(config)# interface gigabitethernet0/2 Switch(config-if)# no switchport

Switch(config-if)# ip address 192.20.135.21 255.255.255.0 Switch(config-if)# no shutdown

配置 VLAN

configure terminal  进入配置状态

vlan vlan-id  输入一个 VLAN 号,  然后进入 vlan 配态,可以输入一个新的 VLAN 号或旧的来进 行修改

name vlan-name  可选)输入一个 VLAN 名,如果没有配置 VLAN 名,缺省的名字是 VLAN 号前 面用 0 填满

的 4 位数,如 VLAN0004 是 VLAN4 的缺省名字

mtu mtu-size (可选)  改变 MTU 大小 例

Switch# configure terminal Switch(config)# vlan 20 Switch(config-vlan)# name test20 Switch(config-vlan)# end

Switch# vlan database Switch(vlan)# vlan 20 name test20 Switch(vlan)# exit

将端口分配给一个 VLAN

configure terminal  进入配置状态 interface interface-id  进入要分配的端口 switchport mode access  定义二层口

switchport access vlan vlan-id  把端口分配给某一 VLAN

Switch# configure terminal

Enter configuration commands, one per line. End with CNTL/Z. Switch(config)# interface fastethernet0/1

Switch(config-if)# switchport mode access Switch(config-if)# switchport access vlan 2

 

Switch(config-if)# end Switch#

配置 VLAN trunk

configure terminal  进入配置状态

interface interface-Id  进入端口配置状态

switchport trunk encapsulation {isl | dot1q | negotiate}配置 trunk 封装 ISL  或 802.1Q  或

自动协商

switchport mode {dynamic {auto | desirable} | trunk}  配置二层 trunk 模式。

dynamic auto—自动协商是否成为 trunk

dynamic desirable—把端口设置为 trunk 如果对方端口是 trunk, desirable,  配置 Native VLAN

(802.1q)

或自动模式,trunk—设置端口为强制的 trunk 方式,而不理会对方端口是否为 trunk switchport access vlan vlan-id  可选)  指定一个缺省 VLAN,  如果此端口不再是 trunk switchport trunk native vlan vlan-id  指定 802.1Q native VLAN 号

例:

Switch# configure terminal

Enter configuration commands, one per line. End with CNTL/Z. Switch(config)# interface fastethernet0/4

Switch(config-if)# switchport mode trunk

Switch(config-if)# switchport trunk encapsulation dot1q Switch(config-if)# end

定义 TRUNK 允许的 VLAN

configure terminal 子 进入配置状态 interface interface-id  进入端口配置 switchport mode trunk  配置二层口为 trunk

switchport trunk allowed vlan {add | all | except | remove} vlan-list 可选)  配置 trunk 允

许的 VLAN.使用 add, all, except, remove 关健字

no switchport trunk allowed vlan  允许所有 VLAN 通过 例

Switch(config)# interface fastethernet0/1

Switch(config-if)# switchport trunk allowed vlan remove 2 Switch(config-if)# end

配置 Native VLAN(802.1q)

configure terminal  进入配置状态

interface interface-id  进入配置成 802.1qtrunk 的端口

switchport trunk native vlan vlan-Id  配置 native VLAN 号

no switchport trunk native vlan  端口配置命令回到缺省的状态 配置基于端口权值的负载均衡

configure terminal  进入 Switch 1 配置状态

vtp domain domain-name  配置 VTP 域

vtp mode server  将 Switch 1 配置成 VTP server.

 

show vtp status  验证 VTP 的配置

show vlan  验证 VLAN

configure terminal  进入配置状态

interface fastethernet 0/1  进入 F0/1 端口

switchport trunk encapsulation {isl | dot1q | negotiate}配置 trunk 封装

switchport mode trunk  配置成 trunk

show interfaces fastethernet0/1 switchport  验证 VLAN 配置 按以上步骤对想要负载均衡的接口进行配置 在另一个交换机上进行此配置

show vlan  当 trunk 已经起来,在 switch2 上验证已经学到相的 vlan 配置

configure terminal  在 Switch 1 上进入配置状态

interface fastethernet0/1  进入要配置的端口

spanning-tree vlan 8 port-priority 10  将端口权值 10 赋与 VLAN 8.

spanning-tree vlan 9 port-priority 10  将端口权值 10 赋与 VLAN 9.

spanning-tree vlan 10 port-priority 10  将端口权值 10 赋与 VLAN 10. interface fastethernet0/2  进入 F0/2

spanning-tree vlan 3 port-priority 10  将端口权值 10 赋与 VLAN 3.

spanning-tree vlan 4 port-priority 10  将端口权值 10 赋与 VLAN 4

spanning-tree vlan 5 port-priority 10  将端口权值 10 赋与 VLAN 5

spanning-tree vlan 6 port-priority 10  将端口权值 10 赋与 VLAN 10 end  退出

show running-config  验证配置

copy running-config startup-config  保存配置

配置 STP 路径值的负载均衡

Trunk1 走 VLAN8-10,Trunk2 走 VLAN2-4

configure terminal  进入 Switch 1 配置状态

interface fastethernet 0/1  进入 F0/1

switchport trunk encapsulation {isl | dot1q | negotiate}配置封装 switchport mode trunk  配置 Trunk,缺省是 ISL 封装

exit  退回

在 F0/2 口上重复 2-4 步骤

exit  退回

show running-config  验证配置

show vlan 验证 switch1  已经学到 Vlan configure terminal  进入配置状态 interface fastethernet 0/1  进入 F0/1

spanning-tree vlan 2 cost 30  设置 Vlan2 生成树路径值为 30

spanning-tree vlan 3 cost 30  设置 Vlan3 生成树路径值为 30

spanning-tree vlan 4 cost 30  设置 Vlan4 生成树路径值为 30 end  退出

在 switch1 的 F0/2 上重复 9-11 步骤设置 VLAN8,9,10 生成树路径值为 30 end  退出

 

show running-config  验证配置

copy running-config startup-config  保存配置

补充:CISCO 命令集——路由选择协议及排障

*ip route 命令

Router(config)# ip route <目录网络或子网号> [子网掩码] <下一路由器 IP 地址 |  从本地出口 的地址> [管理距离 0~255,默认为 1]

(注:静态地址配置)

*ip default-network 命令

Router(config)# ip default-network <目标网络号> (注:配合路由协使用,用其中的一个动态路由号作默认路由配置)

Router(config)# ip route 0.0.0.0 0.0.0.0 <下一路由器 IP 地址 |  从本地出口的地址> (注:只有一个公网地址时,在出口路由器上的配置)

*内部路由选择协议

*使用 router 和 network 命令

Router(config)# router <路由协议 rip | igrp | eigrp | ospf | is-is 等> [自主系统号] Router(config-router)# network <直接相连的要用此路由协议的网络号> Router(config-router)# network <直接相连的要用此路由协议的网络号>

*路由信息协议 RIP Router(config)# router rip

Router(config-router)# network <直接相连的要用 rip 协议的有类别网络号>

Router# show ip protocols Router# show ip route Router# debug ip rip

*内部网关路由协议 IGRP Router(config)# router igrp <自主系统号>

Router(config-router)# network <直接相连的要用 igrp 协议的有类别网络号>

Router# show ip interface Router# show ip protocols Router# show ip route Router# debug ip rip

*排除网络故障

 

排除网络故障的一个总体模型

Router# ping <有故障的主机 |  有故障的 IP 地址> Router# show ip route

Router# show interface <有故障的接口>

Router# show run

*IP 的故故障排除 检查可用的路由

Router# show ip route <有故障的 IP 地址>

27.4.4  跟踪路由(Tracing the Route)

SUN-A> traceroute <有故障的主机 |  有故障的 IP 地址> C:\windows\> winipcfg

C:\windows\> ipconfig C:\windows\> ipconfig / all

C:\windows\> tracert <有故障的主机 |  有故障的 IP 地址>

使用扩展的 ping 来跟踪连接性

Router# ping

*其它可能的故障 一个地址解析(ARP)的故障

Router# show arp

Router# show interface <有故障的接口> C:\windows\> arp -a

SUN-A> arp –a

验证终端系统的路由表

C:\windows\> netstat –rn

C:\windows\> route  –f add 0.0.0.0 mask 0.0.0.0 <需要添加入的网关地址> C:\windows\> route [–f ] [[print | add | delete | change] [destination] [mask

netmask] [gateway]]

C:\windows\> route add mask <网络掩码> <网关 ip 地址> C:\windows\> route delete mask <网络掩码> <网关 ip 地址> C:\windows\> nbtstat <相应的参数>

SUN-A> netstat -rn 路由器

 

CISCO 交换机配置命令大全 2009-08-13 21:131.在基于 IOS 的交换机上设置主机名/系统名: switch(config)# hostname hostname

在基于 CLI 的交换机上设置主机名/系统名:

switch(enable) set system name name-string

2.在基于 IOS 的交换机上设置登录口令: switch(config)# enable password level 1 password 在基于 CLI 的交换机上设置登录口令: switch(enable) set password

switch(enable) set enalbepass

3.在基于 IOS 的交换机上设置远程访问: switch(config)# interface vlan 1

switch(config-if)# ip address ip-address netmask switch(config-if)# ip default-gateway ip-address 在基于 CLI 的交换机上设置远程访问:

switch(enable) set interface sc0 ip-address netmask broadcast-address switch(enable) set interface sc0 vlan

switch(enable) set ip route default gateway

4.在基于 IOS 的交换机上启用和浏览 CDP 信息: switch(config-if)# cdp enable

switch(config-if)# no cdp enable

为了查看 Cisco 邻接设备的 CDP 通告信息: switch# show cdp interface [type modle/port]

switch# show cdp neighbors [type module/port] [detail] 在基于 CLI 的交换机上启用和浏览 CDP 信息: switch(enable) set cdp {enable|disable} module/port 为了查看 Cisco 邻接设备的 CDP 通告信息:

switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]

5.基于 IOS 的交换机的端口描述: switch(config-if)# description description-string 基于 CLI 的交换机的端口描述:

switch(enable)set port name module/number description-string

 

6.在基于 IOS 的交换机上设置端口速度: switch(config-if)# speed{10|100|auto} 在基于 CLI 的交换机上设置端口速度:

switch(enable) set port speed moudle/number {10|100|auto} switch(enable) set port speed moudle/number {4|16|auto}

7.在基于 IOS 的交换机上设置以太网的链路模式: switch(config-if)# duplex {auto|full|half}

在基于 CLI 的交换机上设置以太网的链路模式:

switch(enable) set port duplex module/number {full|half}

8.在基于 IOS 的交换机上配置静态 VLAN: switch# vlan database

switch(vlan)# vlan vlan-num name vla

switch(vlan)# exit

switch# configure teriminal

switch(config)# interface interface module/number switch(config-if)# switchport mode access switch(config-if)# switchport access vlan vlan-num switch(config-if)# end

在基于 CLI 的交换机上配置静态 VLAN:

switch(enable) set vlan vlan-num [name name] switch(enable) set vlan vlan-num mod-num/port-list

9.  在基于 IOS 的交换机上配置 VLAN 中继线: switch(config)# interface interface mod/port switch(config-if)# switchport mode trunk

switch(config-if)# switchport trunk encapsulation {isl|dotlq} switch(config-if)# switchport trunk allowed vlan remove vlan-list switch(config-if)# switchport trunk allowed vlan add vlan-list 在基于 CLI 的交换机上配置 VLAN 中继线:

switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate] Vlan-range [isl|dotlq|dotl0|lane|negotiate]

10.在基于 IOS 的交换机上配置 VTP 管理域: switch# vlan database

switch(vlan)# vtp domain domain-name 在基于 CLI 的交换机上配置 VTP 管理域: switch(enable) set vtp [domain domain-name]

11.在基于 IOS 的交换机上配置 VTP  模式: switch# vlan database

switch(vlan)# vtp domain domain-name

 

switch(vlan)# vtp {sever|cilent|transparent} switch(vlan)# vtp password password 在基于 CLI 的交换机上配置 VTP  模式:

switch(enable)  set  vtp  [domain  domain-name]  [mode{  sever|cilent|transparent  }][password password]

12.  在基于 IOS 的交换机上配置 VTP 版本: switch# vlan database

switch(vlan)# vtp v2-mode

在基于 CLI 的交换机上配置 VTP 版本: switch(enable) set vtp v2 enable

13.  在基于 IOS 的交换机上启动 VTP 剪裁: switch# vlan database

switch(vlan)# vtp pruning

在基于 CL I  的交换机上启动 VTP 剪裁: switch(enable) set vtp pruning enable

14.在基于 IOS 的交换机上配置以太信道:

switch(config-if)# port group group-number [distribution {source|destination}]

在基于 CLI 的交换机上配置以太信道:

switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}

15.在基于 IOS 的交换机上调整根路径成本: switch(config-if)# spanning-tree [vlan vlan-list] cost cost 在基于 CLI 的交换机上调整根路径成本:

switch(enable) set spantree portcost moudle/port cost

switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list]

16.在基于 IOS 的交换机上调整端口 ID:

switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority

在基于 CLI 的交换机上调整端口 ID:

switch(enable) set spantree portpri {mldule/port}priority switch(enable) set spantree portvlanpri {module/port}priority [vlans]

17.  在基于 IOS 的交换机上修改 STP 时钟:

switch(config)# spanning-tree [vlan vlan-list] hello-time seconds switch(config)# spanning-tree [vlan vlan-list] forward-time seconds

` switch(config)# spanning-tree [vlan vlan-list] max-age seconds

在基于 CLI 的交换机上修改 STP 时钟: switch(enable) set spantree hello interval[vlan] switch(enable) set spantree fwddelay delay [vlan] switch(enable) set spantree maxage agingtiame[vlan]

 

18.  在基于 IOS 的交换机端口上启用或禁用 Port Fast  特征: switch(config-if)#spanning-tree portfast

在基于 CLI 的交换机端口上启用或禁用 Port Fast  特征:

switch(enable) set spantree portfast {module/port}{enable|disable}

19.  在基于 IOS 的交换机端口上启用或禁用 UplinkFast  特征: switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second] 在基于 CLI 的交换机端口上启用或禁用 UplinkFast  特征:

switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on]

20.  为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个 IP 地址,然后使 用下列命令: switch(config)# cluster enable cluster-name

21.  为了从一条中继链路上删除 VLAN,可使用下列命令: switch(enable) clear trunk module/port vlan-range

22. 用 show vtp domain  显示管理域的 VTP 参数.

23. 用 show vtp statistics 显示管理域的 VTP 参数.

24. 在 Catalyst 交换机上定义 TrBRF 的命令如下:

switch(enable) set vlan vlan-name [name name] type trbrf bridge bridge-num[stp {ieee|ibm}]

25. 在 Catalyst 交换机上定义 TrCRF 的命令如下:

switch (enable) set vlan vlan-num [name name] type trcrf

{ring hex-ring-num|decring decimal-ring-num} parent vlan-num

26.  在创建好 TrBRF VLAN 之后,就可以给它分配交换机端口.对于以太网交换,可以采用如下命 令给 VLAN 分配端口:

switch(enable) set vlan vlan-num mod-num/port-num

27.  命令 show spantree 显示一个交换机端口的 STP 状态. 28.  配置一个 ELAN 的 LES 和 BUS,可以使用下列命令:

ATM (config)# interface atm number.subint multioint ATM(config-subif)# lane serber-bus ethernet elan-name

29.  配置 LECS:

ATM(config)# lane database database-name

ATM(lane-config-databade)# name elan1-name server-atm-address les1-nsap-address ATM(lane-config-databade)# name elan2-name server-atm-address les2-nsap-address ATM(lane-config-databade)# name …

 

30.  创建完数据库后,必须在主接口上启动 LECS.命令如下: ATM(config)# interface atm number

ATM(config-if)# lane config database database-name ATM(config-if)# lane config auto-config-atm-address

31.  将每个 LEC 配置到一个不同的 ATM 子接口上.命令如下: ATM(config)# interface atm number.subint multipoint ATM(config)# lane client ethernet vlan-num elan-num

32. 用 show lane server  显示 LES 的状态.

33. 用 show lane bus 显示 bus 的状态.

34. 用 show lane database 显示 LECS 数据库可内容.

35. 用 show lane client 显示 LEC 的状态.

36.  用 show module 显示已安装的模块列表. 37.  用物理接口建立与 VLAN 的连接:

router# configure terminal

router(config)# interface media module/port router(config-if)# description description-string router(config-if)# ip address ip-addr subnet-mask router(config-if)# no shutdown

38.  用中继链路来建立与 VLAN 的连接: router(config)# interface module/port.subinterface router(config-ig)# encapsulation[isl|dotlq] vlan-number router(config-if)# ip address ip-address subnet-mask

39.  用 LANE  来建立与 VLAN 的连接: router(config)# interface atm module/port router(config-if)# no ip address router(config-if)# atm pvc 1 0 5 qsaal

router(config-if)# atm pvc 2 0 16 ilni

router(config-if)# interface atm module/port.subinterface multipoint router(config-if)# ip address ip-address subnet-mask

router(config-if)# lane client ethernet elan-num

router(config-if)# interface atm module/port.subinterface multipoint router(config-if)# ip address ip-address subnet-name

router(config-if)# lane client ethernet elan-name router(config-if)# …

 

40.  为了在路由处理器上进行动态路由配置,可以用下列 IOS 命令来进行: router(config)# ip routing

router(config)# router ip-routing-protocol router(config-router)# network ip-network-number router(config-router)# network ip-network-number

41.  配置默认路由:

switch(enable) set ip route default gateway

42.  为一个路由处理器分配 VLANID,可在接口模式下使用下列命令: router(config)# interface interface number

router(config-if)# mls rp vlan-id vlan-id-num

43.  在路由处理器启用 MLSP: router(config)# mls rp ip

44.  为了把一个外置的路由处理器接口和交换机安置在同一个 VTP 域中: router(config)# interface interface number

router(config-if)# mls rp vtp-domain domain-name

45.  查看指定的 VTP 域的信息:

router# show mls rp vtp-domain vtp domain name

46.  要确定 RSM 或路由器上的管理接口,可以在接口模式下输入下列命令: router(config-if)#mls rp management-interface

47.  要检验 MLS-RP 的配置情况:

router# show mls rp

48.  检验特定接口上的 MLS 配置:

router# show mls rp interface interface number

49.  为了在 MLS-SE 上设置流掩码而又不想在任一个路由处理器接口上设置访问列表:

set mls flow [destination|destination-source|full]

50.  为使 MLS 和输入访问列表可以兼容,可以在全局模式下使用下列命令:

router(config)# mls rp ip input-acl

51.  当某个交换机的第 3 层交换失效时,可在交换机的特权模式下输入下列命令:

switch(enable) set mls enable

52.  若想改变老化时间的值,可在特权模式下输入以下命令:

switch(enable) set mls agingtime agingtime

 

53.  设置快速老化:

switch(enable) set mls agingtime fast fastagingtime pkt_threshold

54.  确定那些 MLS-RP 和 MLS-SE 参与了 MLS,可先显示交换机引用列表中的内容再确定: switch(enable) show mls include

55.  显示 MLS 高速缓存记录:

switch(enable) show mls entry

56.  用命令 show in arp 显示 ARP 高速缓存区的内容。

57.  要把路由器配置为 HSRP 备份组的成员,可以在接口配置模式下使用下面的命令:

router(config-if)# standby group-number ip ip-address

58.  为了使一个路由器重新恢复转发路由器的角色,在接口配置模式下:

router(config-if)# standy group-number preempt

59.  访问时间和保持时间参数是可配置的:

router(config-if)# standy group-number timers hellotime holdtime

60.  配置 HSRP 跟踪:

router(config-if)# standy group-number track type-number interface-priority

61.  要显示 HSRP 路由器的状态:

router# show standby type-number group brief 62.  用命令 show ip igmp 确定当选的查询器。

63.  启动 IP 组播路由选择:

router(config)# ip muticast-routing

64.  启动接口上的 PIM:

dalllasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode}

65.  启动稀疏-稠密模式下的 PIM: router# ip multicast-routing

router# interface type number router# ip pim sparse-dense-mode

66.  核实 PIM 的配置:

dallasr1># show ip pim interface[type number] [count]

67.  显示 PIM 邻居:

dallasr1># show ip neighbor type number

 

68.  为了配置 RP 的地址,命令如下:

dallasr1># ip pim rp-address ip-address [group-access-list-number][override]

69.  选择一个默认的 RP: dallasr1># ip pim rp-address

通告 RP 和它所服务的组范围:

dallasr1># ip pim send-rp-announce type number scope ttl group-list access-list-number

为管理范围组通告 RP 的地址:

dallasr1># ip pim send-rp-announce ethernet0 scope 16 group-list1 dallasr1># access-list 1 permit 266.0.0.0 0.255.255.255

设定一个 RP 映像代理:

dallasr1># ip pim send-rp-discovery scope ttl

核实组到 RP 的映像:

dallasr1># show ip pim rp mapping

dallasr1># show ip pim rp [group-name|group-address] [mapping]

70. 在路由器接口上用命令 ip multicast ttl-threshold ttl-value 设定 TTL 阀值:

dallasr1>(config-if)# ip multicast ttl-threshold ttl-value

71. 用 show ip pim neighbor 显示 PIM 邻居表。

72.  显示组播通信路由表中的各条记录:

dallasr1>show ip mroute [group-name|group-address][scoure][summary][count][active kbps]

73.  要记录一个路由器接受和发送的全部 IP 组播包:

dallasr1> #debug ip mpacket [detail] [access-list][group]

74.  要在 CISCO 路由器上配置 CGMP: dallasr1>(config-if)# ip cgmp

75.配置一个组播路由器,使之加入某一个特定的组播组: dallasr1>(config-if)# ip igmp join-group group-address

76.  关闭 CGMP: dallasr1>(config-if)# no ip cgmp

77.  启动交换机上的 CGMP: dallasr1>(enable) set cgmp enable

78.  核实 Catalyst 交换机上 CGMP 的配置情况:

catalystla1>(enable) show config set prompt catalystla1>

set interface sc0 192.168.1.1 255.255.255.0

 

set cgmp enable

79. CGMP 离开的设置:

Dallas_SW(enable) set cgmp leave

80.  在 Cisco 设备上修改控制端口密码:

R1(config)# line console 0 R1(config-line)# login

R1(config-line)# password Lisbon R1(config)# enable password Lilbao R1(config)# login local

R1(config)# username student password cisco

81.  在 Cisco 设备上设置控制台及 vty 端口的会话超时:

R1(config)# line console 0 R1(config-line)# exec-timeout 5 10

R1(config)# line vty 0 4

R1(config-line)# exec-timeout 5 2

82.  在 Cisco 设备上设定特权级:

R1(config)# privilege configure level 3 username R1(config)# privilege configure level 3 copy run start R1(config)# privilege configure level 3 ping R1(config)# privilege configure level 3 show run R1(config)# enable secret level 3 cisco

83.  使用命令 privilege  可定义在该特权级下使用的命令:

router(config)# privilege mode level level command

84.  设定用户特权级:

router(config)# enable secret level 3 dallas router(config)# enable secret san-fran router(config)# username student password cisco

85.  标志设置与显示:

R1(config)# banner motd ‘unauthorized access will be prosecuted!’

86.  设置 vty 访问:

R1(config)# access-list 1 permit 192.168.2.5

R1(config)# line vty 0 4 R1(config)# access-class 1 in

87.  配置 HTTP 访问:

Router3(config)# access-list 1 permit 192.168.10.7

 

Router3(config)# ip http sever Router3(config)# ip http access-class 1 Router3(config)# ip http authentication local

Router3(config)# username student password cisco

88.  要启用 HTTP 访问,请键入以下命令:

switch(config)# ip http sever

89.  在基于 set 命令的交换机上用 setCL1 启动和核实端口安全: switch(enable) set port security mod_num/port_num…enable mac address switch(enable) show port mod_num/port_num

在基于 CiscoIOS 命令的交换机上启动和核实端口安全:

switch(config-if)# port secure [mac-mac-count maximum-MAC-count] switch# show mac-address-table security [type module/port]

90.  用命令 access-list 在标准通信量过滤表中创建一条记录:

Router(config)# access-list access-list-number {permit|deny} source-address [source-address]

91.  用命令 access-list 在扩展通信量过滤表中创建一条记录:

Router(config)# access-list access-list-number {permit|deny{protocol|protocol-keyword}}{source source-wildcard|any}{destination destination-wildcard|any}[protocol-specific options][log]

92.  对于带内路由更新,配置路由更新的最基本的命令格式是:

R1(config-router)#distribute-list access-list-number|name in [type number]

93.  对于带外路由更新,配置路由更新的最基本的命令格式是:

R1(config-router)#distribute-list access-list-number|name out [interface-name] routing-process| autonomous-system-number

94. set snmp 命令选项:

set snmp community {read-only|ready-write|read-write-all}[community_string]

95. set snmp trap  命令格式如下:

set snmp trap {enable|disable}

[all|moudle|classis|bridge|repeater| auth|vtp|ippermit|vmps|config|entity|stpx] set snmp trap rvcr_addr rcvr_community

96. 启用 SNMP chassis  陷阱: Console>(enable) set snmp trap enable chassis

97. 启用所有 SNMP chassis  陷阱: Console>(enable) set snmp trap enable

98. 禁用 SNMP chassis  陷阱:

 

Console>(enable) set snmp trap disable chassis

99.  给 SNMP 陷阱接收表加一条记录:

Console>(enable) set snmp trap 192.122.173.42 public

100. show snmp  输出结果。

101. 命令 set snmp rmon enable  的输出结果。

102.  显示 SPAN 信息:

Consile> show span

一些华为路由器命令: 删除设备配置

reset saved-configuration

重启

reboot

看当前配置文件

display current-configuration

改设备名

sysname

保存配置

save

进入特权模式

sysview

华为只有 2 层模式 不像 cisco enale 之后还要 conf t

定义 acl

acl nubmere XXXX(3000 以上)进入以后

rule permit/deny IP/TCP/UDP 等 source XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX(反向) destination XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX(反向) eq

注意 华为默认没有 deny any any

防火墙上端口加载 ACL

[Quidway-Ethernet0/0]firewall packet-filter 3000 inbound

 

防火墙上新增加用户

local-user XXX(用户名) password simple XXX(密码) local-user XXX service-type ppp

删除某条命令

undo(类似与 cisco 的 no)

静态路由

ip route-static 0.0.0.0 0.0.0.0 XXX.XXX.XXX.XXX

对 vpdn 用户设置 acl 的接口

inte***ce Virtual-Template1

查看路由表

display ip routing-table

设定 telnet 密码

user-inte***ce vty 0 4 user privilege level 3

set authentication password simple XXX

启动/关闭 启动 un shut 关闭 shut

动态 nat 设置

acl number 3000

rule 0 permit ip source XXX.XXX.XXX.XXX rule 1 permit ip source XXX.XXX.XXX.XXX rule 2 permit ip source XXX.XXX.XXX.XXX inte***ce Ethernet1/0

des cription ====To-Internet(WAN)====

ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX

nat outbound 3000 ipsec policy policy1

利用 acl 来做 符合 acl 的 IP 地址可以出去(注意 此处的 ACL 隐含了 deny any any)不符合

的 IP 地址不可以出去

创建 vlan

[shzb-crsw-s6506-1]vlan 100

华为 vlan 不支持 name

将 port 放入 vlan

创建了 vlan 后 进入 vlan 模式

 

[shzb-crsw-s6506-1-vlan100]port GigabitEthernet 1/0/1 to GigabitEthernet 1/0/8

表示从 G1/0/1  到 1/0/8 放入 VLAN 100

创建 trunk

inte***ce GigabitEthernet1/0/1 duplex full

speed 1000

* port link-type trunk

* port trunk permit vlan all port link-aggregation group 1

带*号的是创建 trunk 链路的语句

vlan 地址指定

inte***ce Vlan-inte***ce2 des cription server

ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX

vrrp vrid 2 virtual-ip XXX.XXX.XXX.XXX vrrp vrid 2 priority 120

vrrp vrid 2 preempt-mode timer delay 10 其中 vrrp 语句指定 vrrp  类似与 hsrp 使用 vrrp 要注意的是华为不支持 pvst 只能一台完全是主,一台完全是备份 在主 vrrp 设备上要指定

stp instance 0 root primary stp TC-protection enable stp enable

在从 vrrp 设备上要指定

stp instance 0 root secondary stp TC-protection enable

stp enable

交换机下面绑 acl

首先进入接口模式,输入 qos 命令

[shzb-crsw-s6506-1-GigabitEthernet1/0/1]qos

在输入如下命令

[shzb-crsw-s6506-1-qoss-GigabitEthernet1/0/1]packet-filter inbound ip-group 3000

华为交换机只能指定 inbound 方向

启用 ospf

[shzb-crsw-s6506-1]ospf 100

[shzb-crsw-s6506-1-ospf-100]area 0

[shzb-crsw-s6506-1-ospf-100-area-0.0.0.0]network XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX

配置 ospf 重发布

[shzb-crsw-s6506-1-ospf-100-area-0.0.0.0]quit

 

[shzb-crsw-s6506-1-ospf-100]import-route static

建立 link-group(类似与 cisco 的 channel-group) link-aggregation group 1 mode manual

然后进入接口

port link-aggregation group 1

启用 VRRP 之前必须输入 vrrp ping-enable 使得客户能 ping 网关

anzhihe安志合个人博客,版权所有丨 如未注明,均为原创 丨转载请注明转自:https://chegva.com/1422.html | ☆★★每天进步一点点,加油!★★☆

您可能还感兴趣的文章!

发表评论

电子邮件地址不会被公开。 必填项已用*标注