H3C交换机常用命令及基本配置

H3C交换机常用命令 

1.查看Linux下查看端口状态

root@root:~# netstat -an|grep -E "6002|6003"

2.H3C交换机显示当前配置

[H3C]display current-configuration

3.H3C交换机显示arp信息

[H3C]dis arp

4.H3C交换机显示mac列表信息

[H3C]dis mac-address

5.H3C交换机显示端口信息

[H3C]display interface

6.进入系统视图

<H3C>system-view

7.打开路由器的telnet功能

[H3C]telnet server enable

8.设置允许同时配置路由器的用户数

[H3C]configure-user count 5

9.添加本地用户(此处为telnet用户登录时使用的用户名)

[H3C]local-user telnet

10.设置telnet用户登录时所使用的密码

[H3C-luser-telnet]password simple h3c

11.设置本地用户的服务类型(此处为telnet)

[H3C-luser-telnet]service-type telnet

12.设置本地用户的服务级别

[H3C-luser-telnet]level 3

13.退出本地用户视图

[H3C-luser-telnet]quit

14.进入用户视图

[H3C]user-interface vty 0 4

15.选择“scheme”认证方式

[H3C-ui-vty0-4]authentication-mode scheme

16.进入某个端口

[H3C] interface serial 3/0

17.为该端口设置ip

[H3C-Serial3/0]ip address 200.1.1.1 255.255.255.0

18.对该端口进行复位

[H3C-Serial3/0]undo shutdown

19.添加一条静态路由

[H3C]ip route-static 192.168.1.0 255.255.255.0 192.168.0.1

20.添加一条默认路由

[H3C]ip route-static 0.0.0.0  0.0.0.0  192.168.0.1

21.保存配置文件

[H3C]save

22.查看某端口的状态

[H3C]display interface GigabitEthernet 0/0

23.创建vlan

[H3C]vlan 10

24.将某个端口加入到vlan

[H3C-vlan100]port ethernet 0/1

25.创建vlan虚拟口

[H3C]interface vlan-interface 1

26.配置ip地址

[H3C-Vlan-interface100]ip address 192.168.1.4  255.255.255.0

27.将端口类型设置为trunk

[H3C]port  link-type trunk

28.设置trunk口允许所有vlan通过(需要执行save保存)

[H3C]port  trunk permit vlan all 

注意:Trunk 可以收发多个vlan的报文,用于交换机与交换机之间的互连

29.关闭端口

[H3C-GigabitEthernet1/1/1]shutdown

30.设置端口备注

[H3C-Ethernet1/0/15]description 测试数据

6.切换端口vlan

操作

命令

说明

进入系统视图

system-view

进入网口

interface ethernet interface_num

网口注意千兆口,百兆口等;

Access端口加入指定VLAN

port access vlan vlan-id

vlan-id:IEEE 802.1q中定义的VLAN ID,取值范围为24094

Access端口从指定VLAN中删除

undo port access vlan

http://blog.csdn.net/xmtblog/article/details/46649759


H3C交换机系统基本配置

一.用户配置:

<H3C>system-view

[H3C]super password H3C     设置用户分级密码

[H3C]undo super password     删除用户分级密码

[H3C]local user bigheap 123456 1     Web网管用户设置,1(缺省)为管理级用户,缺省admin,admin

[H3C]undo localuser bigheap     删除Web网管用户

[H3C]user-interface aux 0     只支持0

[H3C-Aux]idle-timeout 2 50     设置超时为250,若为0则表示不超时,默认为5分钟

[H3C-Aux]undo idle-timeout     恢复默认值

[H3C]user-interface vty 0     只支持01

[H3C-vty]idle-timeout 2 50     设置超时为250,若为0则表示不超时,默认为5分钟

[H3C-vty]undo idle-timeout     恢复默认值

[H3C-vty]set authentication password 123456     设置telnet密码,必须设置

[H3C-vty]undo set authentication password     取消密码

[H3C]display users     显示用户

[H3C]display user-interface     显示用户界面状态

 

.系统IP配置:

[H3C]vlan 20

[H3C]management-vlan 20

[H3C]interface vlan-interface 20     创建并进入管理VLAN

[H3C]undo interface vlan-interface 20     删除管理VLAN接口

[H3C-Vlan-interface20]ip address 192.168.1.2 255.255.255.0     配置管理VLAN接口静态IP地址(缺省为192.168.0.234)

[H3C-Vlan-interface20]undo ip address     删除IP地址

[H3C-Vlan-interface20]ip gateway 192.168.1.1     指定缺省网关(默认无网关地址)

[H3C-Vlan-interface20]undo ip gateway

[H3C-Vlan-interface20]shutdown     关闭接口

[H3C-Vlan-interface20]undo shutdown     开启

[H3C]display ip     显示管理VLAN接口IP的相关信息

[H3C]display interface vlan-interface 20     查看管理VLAN的接口信息

<H3C>debugging ip     开启IP调试功能

<H3C>undo debugging ip

 

.DHCP客户端配置:

[H3C-Vlan-interface20]ip address dhcp-alloc     管理VLAN接口通过DHCP方式获取IP地址

[H3C-Vlan-interface20]undo ip address dhcp-alloc     取消

[H3C]display dhcp     显示DHCP客户信息

<H3C>debugging dhcp-alloc     开启DHCP调试功能

<H3C>undo debugging dhcp-alloc

 

.端口配置:

[H3C]interface Ethernet0/3

[H3C-Ethernet0/3]shutdown

[H3C-Ethernet0/3]speed 100     速率,可为10,100,1000auto(缺省)

[H3C-Ethernet0/3]duplex full     双工,可为half,fullauto(缺省光口和汇聚后不能配置

[H3C-Ethernet0/3]flow-control     开启流控,默认为关闭

[H3C-Ethernet0/3]broadcast-suppression 20     设置抑制广播百分比为20%,可取5,10,20,100,缺省为100,同时组播和未知单播也受此影响

[H3C-Ethernet0/3]loopback internal     内环测试

[H3C-Ethernet0/3]loopback external     外环测试,需插接自环头,必须为全双工或者自协商模式

[H3C-Ethernet0/3]port link-type trunk     设置链路的类型为trunk,可为access(缺省),trunk

[H3C-Ethernet0/3]port trunk pvid vlan 20     设置20为该trunk的缺省VLAN,默认为1(trunk线路两端的PVID必须一致)

[H3C-Ethernet0/3]port access vlan 20     将当前access端口加入指定的VLAN

[H3C-Ethernet0/3]port trunk permit vlan all     允许所有的VLAN通过当前的trunk端口,可多次使用该命令

[H3C-Ethernet0/3]mdi auto     设置以太端口为自动监测,normal(缺省)为直通线,across为交叉线                             

[H3C]link-aggregation Ethernet 0/1 to Ethernet 0/4     1-4口加入汇聚组,1为主端口,两端需要同时配置,设置了端口镜像以及端口隔离的端口无法汇聚

[H3C]undo link-aggregation Ethernet 0/1     删除该汇聚组

[H3C]link-aggregation mode egress     配置端口汇聚模式为根据目的MAC地址进行负荷分担,可选为                                      ingress,egressboth,缺省为both

[H3C]monitor-port Ethernet 0/2     将该端口设置为镜像端口,必须先设置镜像端口,删除时必须先删除被镜像端口,而且它们不能同在一个端口,该端口不能在汇聚组中,设置新镜像端口时,新取代旧,被镜像不变

[H3C]mirroring-port Ethernet 0/3 to Ethernet 0/4 both     将端口34设置为被镜像端口,both为同时监控接收和发送的报文,inbound表示仅监控接收的报文,outbound表示仅监控发送的报文

[H3C]display mirror

[H3C]display interface Ethernet 0/3

<H3C>reset counters     清除所有端口的统计信息

[H3C]display link-aggregation Ethernet 0/3     显示端口汇聚信息

[H3C-Ethernet0/3]virtual-cable-test     诊断该端口的电路状况

 

.VLAN配置:

[H3C]vlan 2

[H3C]undo vlan all     删除除缺省VLAN外的所有VLAN,缺省VLAN不能被删除

[H3C-vlan2]port Ethernet 0/4 to Ethernet 0/7     47号端口加入到VLAN2,此命令只能用来加access端口,不能用来增加trunk或者hybrid端口

[H3C-vlan2]port-isolate enable     打开VLAN内端口隔离特性,不能二层转发,默认不启用该功能

[H3C-Ethernet0/4]port-isolate uplink-port vlan 2     设置4VLAN2的隔离上行端口,用于转发二层数据,只能配置一个上行端口,若为trunk,则建议允许所有VLAN通过,隔离不能与汇聚同时配置

[H3C]display vlan all     显示所有VLAN的详细信息

  S1550E支持基于端口的VLAN,通过创建不同的user-group来实现,一个端口可以属于多个user-group,不属于同一个user-group的端口不能互相通信,最多支持50user-group

[H3C]user-group 20     创建user-group 20,默认只存在user-group 1

[H3C-UserGroup20]port Ethernet 0/4 to Ethernet 0/7     47号端口加入到VLAN20,初始时都属于user-group 1

[H3C]display user-group 20     显示user-group 20的相关信息

 

.集群配置:

S2100只能作为成员交换机加入集群中,加入后系统名改为"集群名_成员编号.原系统名"的格式.

即插即用功能通过两个功能实现: 集群管理协议MAC组播地址协商和管理VLAN协商

[H3C]cluster enable    启用群集功能,缺省为启用

[H3C]cluster     进入群集视图

[H3C-cluster]administrator-address H-H-H name switch     H-H-H为命令交换机的MAC,加入switch集群

[switch_1.H3C-cluster]undo administrator-address     退出集群

[H3C]display cluster     显示集群信息

[H3C]management-vlan 2     集群报文只能在管理VLAN中转发,同一集群需在同一个管理VLAN,需在建立集群之前指定管理VLAN

<H3C>debugging cluster

 

.QoS配置:

QoS配置步骤:设置端口的优先级,设置交换机信任报文的优先级方式,队列调度,端口限速

[H3C-Ethernet0/3]priority 7     设置端口优先级为7,默认为0

[H3C]priority-trust cos     设置交换机信任报文的优先级方式为cos(802.1p优先级,缺省值),还可以设为dscp方式(dscp优先级方式)

[H3C]queue-scheduler hq-wrr 2 4 6 8     设置队列调度算法为HQ-WRR(默认为WRR),权重为2,4,6,8

[H3C-Ethernet0/3]line-rate inbound 29     将端口进口速率限制为2Mbps,1-28,速率为rate*8*1024/125,64,128,192...1.792M;29-127,速率为(rate-27)*1024,2M,3M,4M...100M,千兆时可继续往下取,128-240,速率为(rate-115)*8*1024,104M,112M,120M...1000M

[H3C]display queue-scheduler     显示队列调度模式及参数

[H3C]display priority-trust     显示优先级信任模式

 

.系统管理:

[H3C]mac-address blackhole H-H-H vlan 1     VLAN1中添加黑洞MAC

[H3C]mac-address static H-H-H interface Ethernet 0/1 vlan 1     VLAN1中添加端口一的一个mac

[H3C]mac-address timer aging 500     设置MAC地址表的老化时间为500s

[H3C]display mac-address

[H3C]display arp

[H3C]mac-address port-binding H-H-H interface Ethernet 0/1 vlan 1     配置端口邦定

[H3C]display mac-address port-binding

[H3C]display saved-configuration

[H3C]display current-configuration

<H3C>save

[H3C]restore default     恢复交换机出厂默认配置,恢复后需重启才能生效

[H3C]display version

<H3C>reboot

[H3C]display device

[H3C]sysname bigheap

[H3C]info-center enable     启用系统日志功能,缺省情况下启用

[H3C]info-center loghost ip 192.168.0.3     向指定日志主机(只能为UNIXLINUX,不能为Windows)输出信息,需先开启日志功能,缺省关闭

[H3C]info-center loghost level 8     设置系统日志级别为8,默认为5.级别说明:1.emergencies 2.alerts 3.critical 4.errors 5.warnings 6.notifications 7.informational 8.debugging

<H3C>terminal debugging     启用控制台对调试信息的显示,缺省控制台为禁用

<H3C>terminal logging     启用控制台对日志信息的显示,缺省控制台为启用

<H3C>terminal trapping     启用控制台对告警信息的显示,缺省控制台为启用

[H3C]display info-center     显示系统日志的配置和缓冲区记录的信息

[H3C]display logbuffer     显示日志缓冲区最近记录的指定数目的日志信息

[H3C]display trapbuffer     显示告警缓冲区最近记录的指定数目的日志信息

<H3C>reset logbuffer     清除日志缓冲区的信息

<H3C>reset trapbuffer     清除告警缓冲区的信息

 

.网络协议配置:

NDP即是邻居发现协议,S1550E只能开启或关闭NDP,无法配置,默认有效保留时间为180s,NDP报文发送的间隔60s

[H3C]ndp enable     缺省情况下是开启的

[H3C-Ethernet0/3]ndp enable     缺省情况下开启

[H3C]display ndp     显示NDP配置信息

[H3C]display ndp interface Ethernet 0/1     显示指定端口NDP发现的邻居信息

<H3C>debugging ndp interface Ethernet 0/1

  HABP协议即Huawei Authentication Bypass Protocol,华为鉴权旁路协议,是用来解决当交换机上同时配置了802.1xHGMPv1/v2,未经授权和认证的端口上将过滤HGMP报文,从而使管理设备无法管理下挂的交换机的问题。交换机启动HABP,将忽略802.1x认证。

  HABP包括服务器和客户端,由服务器定期发送请求,客户端进行应答,并向下进行转发,服务器一般启动在管理设备上,客户机在下挂设备上启动,1550E只支持客户端。

[H3C]habp enable     启动HABP特性,缺省即启动,启动后即缺省为客户机模式

<H3C>debugging habp     启动HABP调试功能

  NTDP即邻居拓扑发现协议,用来收集网络拓扑信息的协议,NDP协议一起工作,用于集群管理,S1550E的配置主要包括开启与关闭功能能,开启与关闭调试功能

[H3C]ntdp enable     缺省情况下为开启的

[H3C-Ethernet0/3]ntdp enable     缺省情况下为使能

<H3C>debugging ntdp

 

.SNMP配置:

S1550E支持SNMPv1,SNMPv2c,主要配置包括:设置团体名,设置系统信息,设置Trap目标主机的地址,允许或禁止发送Trap,禁止SNMP Agent的运行

[H3C]snmp-agent community read bigheap     设置bigheap团体,且为只读访问

[H3C]snmp-agent max-size 1600     设置Agent能接受/发送的SNMP消息包最大为1600字节,缺省1500

[H3C]snmp-agent sys-info contact #27345 location Diqiu version v2c     设置系统信息,版本为v2c,缺省情况下联系信息为"R&D Hangzhou, H3C Technologies co.,Ltd.",位置为"Hangzhou China",v2c版本

[H3C]undo snmp-agent     禁止SNMP Agent的运行,若配置任何SNMP命令将重新启动SNMP Agent

[H3C]display snmp-agent community read

[H3C]display snmp-agent sys-info contact

[H3C]display snmp-agent sys-info location

[H3C]display snmp-agent sys-info version

<H3C>debugging snmp-agent packet|process

 

十一.IGMP Snooping配置:

IGMP Snooping是运行在二层交换机上的组播约束机制,用于管理和控制组播组.主要负责建立和维护二层MAC地址表,同时根据建立的组播地址表来转发路由器下发的组播报文,如果不运行IGMP Snooping,则组播报文将在二层网络中广播

IGMP Snooping配置包括:启动和关闭IGMP Snooping,配置路由器端口老化时间,配置最大响应查询时间,配置组播组成员端口老化时间,配置端口快速离开,调试功能

[H3C]igmp-snooping      启用IGMP Snooping功能,默认为关闭

[H3C]igmp-snooping router-aging-time 500     配置路由器端口老化时间为500s,默认为105s

[H3C]igmp-snooping max-response-time 15     配置最大响应查询时间为15s,默认为10s

[H3C]igmp-snooping host-aging-time 300     配置组播组成员端口老化时间为300s,默认为260s

[H3C-Ethernet0/3]igmp-snooping fast-leave     配置快速离开,若收到离开报文,则立即删除端口,不询问

[H3C]display igmp-snooping configuration     显示配置信息

[H3C]display igmp-snooping statistics     显示包统计信息

[H3C]display igmp-snooping group vlan 2     显示VLAN2IP组播组和MAC组播组的信息

<H3C>reset igmp-snooping statistics     清楚统计信息

<H3C>debugging igmp-snooping

 

十二.系统调试:

<H3C>debugging all     开启所有调试开关,此命令为协议调试开关

<H3C>terminal debugging     终端调试开关,打开开关,默认为关闭

<H3C>debugging drv     主要显示报文的实际内容,默认为关闭

[H3C]display debugging     显示调试开关状态

 

十三.802.1x配置:

[H3C-Ethernet0/3]dot1x  开启802.1x特性,也可在系统视图下使用,使用后全局开启,也可用interface参数开启指定端口的802.1x特性,缺省全关闭,要启用802.1x,全局和端口的都需开启

[H3C-Ethernet0/3]dot1x port-control unauthorized-force 设置工作模式为强制非授权模式,使用        模式与dot1x命令相同,默认为auto,即通过了认证才可以访问,还有authorized-force,为强制授权模式,允许用户访问

[H3C-Ethernet0/3]dot1x port-method portbased设置接入控制方式为基于端口的,使用模式与dot1x命令相同,默认为macbase,基于MAC地址的

[H3C-Ethernet0/3]dot1x max-user 10设置端口接入用户的数量最大为10,使用模式与dot1x命令         相同,默认为128,取值范围为1-128

[H3C]dot1x authentication-method eap  设置802.1x的用户认证方法为EAP,EAP中继,直接用EAP        文发送到服务器,需服务器支持

[H3C-Ethernet0/3]dot1x re-authenticate  开启802.1x重认证功能使交换机以一定时间间隔周期性的进行认证,使用模式同dot1x命令,缺省情况下所有端口该特性都关闭

[H3C]dot1x timer handshake-period 20 reauth-period 7200 quiet-period 30 tx-period 20 supp-     timeout 20 server-timeout 200   设置802.1x认证的定时器,handshake-period为认证成功后,系统以此间隔为周期发送握手请求报文(相当于keepalive消息发送间隔),1-1024s,默认15s.

     reauth-period为重认证超时定时器,1-86400s,默认3600s.

     quiet-period为用户认证失败后,Autheticator的静默定时器,静默后再处理认证,10-120s,默认60s.

     tx-period为传送超时定时器,Supplicant未成功发送认证应答报文,则重发认证请求,10-120s,默认   30s.

     supp-timeout为认证超时定时器,Supplicant未成功响应,则重发认证请求,10-120s,默认30s.

     server-timeout为服务器未成功响应的超时定时器,100-300s,默认100s.

<H3C>reset dot1x statistics   清除802.1x统计信息

[H3C]display dot1x statistics  显示802.1x的配置,运行情况和统计信息

<H3C>debugging dot1x     打开802.1x的相关模块的调试信息

 

十四.RADIUS配置:

[H3C]radius scheme system     进入system方案,其各项值为缺省值,1550E只支持默认方案

[H3C-radius-system]primary authentication 10.110.1.1 1812     设置RADIUS服务器地址和UDP端口     ,默认情况下,system方案中服务器IP地址为空,UDP端口号为1812

[H3C-radius-system]key authentication 123     指示RADIUS加密共享密钥为123,默认无共享密钥

[H3C-radius-system]timer 10     设置RADIUS服务器响应超时定时器,1-10s,默认为5s

[H3C-radius-system]retry 10     设置RADIUS服务器最大响应重试次数为10,1-20,默认为5

[H3C]display radius     显示radius方案信息

<H3C>debugging radius packet     打开radius报文调试开关

http://www.ict361.com/h3c-technology/95.html

 


华为3COM交换机配置命令详解
1、配置文件相关命令
[Quidway]display current-configuration         ;显示当前生效的配置
[Quidway]display saved-configuration           ;显示flash中配置文件,即下次上电启动时所用的配置文件
<Quidway>reset saved-configuration           ;檫除旧的配置文件
<Quidway>reboot                                    ;交换机重启
<Quidway>display version                          ;显示系统版本信息


2、基本配置
[Quidway]super password                                     ;修改特权用户密码
[Quidway]sysname                                     ;交换机命名
[Quidway]interface ethernet 0/1                            ;进入接口视图
[Quidway]interface vlan x                            ;进入接口视图
[Quidway-Vlan-interfacex]ip address 10.65.1.1 255.255.0.0    ;配置VLANIP地址
[Quidway]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2          ;静态路由=网关


3telnet配置
[Quidway]user-interface vty 0 4                            ;进入虚拟终端
[S3026-ui-vty0-4]authentication-mode password                ;设置口令模式
[S3026-ui-vty0-4]set authentication-mode password simple 222  ;设置口令
[S3026-ui-vty0-4]user privilege level 3                      ;用户级别


4、端口配置
[Quidway-Ethernet0/1]duplex {half|full|auto}                ;配置端口工作状态
[Quidway-Ethernet0/1]speed {10|100|auto}                ;配置端口工作速率
[Quidway-Ethernet0/1]flow-control                      ;配置端口流控
[Quidway-Ethernet0/1]mdi {across|auto|normal}                ;配置端口平接扭接
[Quidway-Ethernet0/1]port link-type {trunk|access|hybrid}    ;设置端口工作模式
[Quidway-Ethernet0/1]undo shutdown                      ;激活端口
[Quidway-Ethernet0/2]quit                            ;退出系统视图


5、链路聚合配置
[DeviceA] link-aggregation group 1 mode manual     ;创建手工聚合组1
[DeviceA] interface ethernet 1/0/1                             ;将以太网端口Ethernet1/0/1加入聚合组1
[DeviceA-Ethernet1/0/1] port link-aggregation group 1
[DeviceA-Ethernet1/0/1] interface ethernet 1/0/2              ;将以太网端口Ethernet1/0/2加入聚合组1
[DeviceA-Ethernet1/0/2] port link-aggregation group 1
[DeviceA] link-aggregation group 1 service-type tunnel        # 在手工聚合组的基础上创建Tunnel业务环回组。
[DeviceA] interface ethernet 1/0/1                                    # 将以太网端口Ethernet1/0/1加入业务环回组。
[DeviceA-Ethernet1/0/1] undo stp
[DeviceA-Ethernet1/0/1] port link-aggregation group 1


6、端口镜像
[Quidway]monitor-port <interface_type interface_num>        ;指定镜像端口
[Quidway]port mirror <interface_type interface_num>      ;指定被镜像端口
[Quidway]port mirror int_list observing-port int_type int_num ;指定镜像和被镜像


7VLAN配置
[Quidway]vlan 3                                        ;创建VLAN
[Quidway-vlan3]port ethernet 0/1 to ethernet 0/4      ;在VLAN中增加端口
配置基于accessVLAN
[Quidway-Ethernet0/2]port access vlan 3               ;当前端口加入到VLAN         
注意:缺省情况下,端口的链路类型为Access类型,所有Access端口均属于且只属于VLAN1
配置基于trunkVLAN
[Quidway-Ethernet0/2]port link-type trunk                          ;设置当前端口为trunk
[Quidway-Ethernet0/2]port trunk permit vlan {ID|All}      ;设trunk允许的VLAN             
注意:所有端口缺省情况下都是允许VLAN1的报文通过的
[Quidway-Ethernet0/2]port trunk pvid vlan 3         ;设置trunk端口的PVID
配置基于Hybrid端口的VLAN
[Quidway-Ethernet0/2]port link-type hybrid                  ;配置端口的链路类型为Hybrid类型
[Quidway-Ethernet0/2]port hybrid vlan vlan-id-list { tagged | untagged }     ;允许指定的VLAN通过当前Hybrid端口 
注意:缺省情况下,所有Hybrid端口只允许VLAN1通过
[Quidway-Ethernet0/2]port hybrid pvid vlan vlan-id              ;设置Hybrid端口的缺省VLAN                                   
注意:缺省情况下,Hybrid端口的缺省VLANVLAN1
VLAN描述
[Quidway]description string                           ;指定VLAN描述字符
[Quidway]description                               ;删除VLAN描述字符
[Quidway]display vlan [vlan_id]                            ;查看VLAN设置
私有VLAN配置
[SwitchA-vlanx]isolate-user-vlan enable               ;设置主vlan
[SwitchA]Isolate-user-vlan <x> secondary <list>         ;设置主vlan包括的子vlan
[Quidway-Ethernet0/2]port hybrid pvid vlan <id>         ;设置vlanpvid
[Quidway-Ethernet0/2]port hybrid pvid                  ;删除vlanpvid
[Quidway-Ethernet0/2]port hybrid vlan vlan_id_list untagged  ;设置无标识的vlan
如果包的vlan idPVId一致,则去掉vlan信息. 默认PVID=1
所以设置PVID为所属vlan id, 设置可以互通的vlanuntagged.


8STP配置
[Quidway]stp {enable|disable}                               ;设置生成树,默认关闭
[Quidway]stp mode rstp                                         ;设置生成树模式为rstp
[Quidway]stp priority 4096                              ;设置交换机的优先级
[Quidway]stp root {primary|secondary}                  ;设置为根或根的备份
[Quidway-Ethernet0/1]stp cost 200                     ;设置交换机端口的花费
MSTP配置:
# 配置MST域名为infoMSTP修订级别为1VLAN映射关系为VLAN2VLAN10映射到生成树实例1上,VLAN20VLAN30映射生成树实例2上。
<Sysname> system-view
[Sysname] stp region-configuration
[Sysname-mst-region] region-name info
[Sysname-mst-region] instance 1 vlan 2 to 10
[Sysname-mst-region] instance 2 vlan 20 to 30
[Sysname-mst-region] revision-level 1
[Sysname-mst-region] active region-configuration


9MAC地址表的操作
在系统视图下添加MAC地址表项
[Quidway]mac-address { static | dynamic | blackhole } mac-address interface interface-type interface-number vlan vlan-id  ;添加MAC地址表项
在添加MAC地址表项时,命令中interface参数指定的端口必须属于vlan参数指定的VLAN,否则将添加失败。
如果vlan参数指定的VLAN是动态VLAN,在添加静态MAC地址之后,会自动变为静态VLAN
在以太网端口视图下添加MAC地址表项 
[Quidway-Ethernet0/2]mac-address { static | dynamic | blackhole } mac-address vlan vlan-id
在添加MAC地址表项时,当前的端口必须属于命令中vlan参数指定的VLAN,否则将添加失败;
如果vlan参数指定的VLAN是动态VLAN,在添加静态MAC地址之后,会自动变为静态VLAN
[Quidway]mac-address timer { aging age | no-aging }   ;设置MAC地址表项的老化时间
注意:缺省情况下,MAC地址表项的老化时间为300秒,使用参数no-aging时表示不对MAC地址表项进行老化。
MAC地址老化时间的配置对所有端口都生效,但地址老化功能只对动态的(学习到的或者用户配置可老化的)MAC地址表项起作用。
[Quidway-Ethernet0/2]mac-address max-mac-count count   ;设置端口最多可以学习到的MAC地址数量
注意:缺省情况下,没有配置对端口学习MAC地址数量的限制。反之,如果端口启动了MAC地址认证和端口安全功能,则不能配置该端口的最大MAC地址学习个数。
[Quidway-Ethernet0/2]port-mac start-mac-address    ;配置以太网端口MAC地址的起始值
在缺省情况下,E126/E126A交换机的以太网端口是没有配置MAC地址的,因此当交换机在发送二层协议报文(例如STP)时,由于无法取用发送端口的MAC地址,
将使用该协议预置的MAC地址作为源地址填充到报文中进行发送。在实际组网中,由于多台设备都使用相同的源MAC地址发送二层协议报文,会造成在某台设备的不
同端口学习到相同MAC地址的情况,可能会对MAC地址表的维护产生影响。
[Quidway]display mac-address       ;显示地址表信息
[Quidway]display mac-address aging-time         ;显示地址表动态表项的老化时间
[Quidway]display port-mac            ;显示用户配置的以太网端口MAC地址的起始值


10GVRP配置
[SwitchA] gvrp      # 开启全局GVRP
[SwitchA-Ethernet1/0/1] gvrp     # 在以太网端口Ethernet1/0/1上开启GVRP
[SwitchE-Ethernet1/0/1] gvrp registration { fixed | forbidden | normal }   #  配置GVRP端口注册模式    缺省为normal 
[SwitchA] display garp statistics [ interface interface-list ]    ;显示GARP统计信息
[SwitchA] display garp timer [ interface interface-list ]       ;显示GARP定时器的值
[SwitchA] display gvrp statistics [ interface interface-list ]    ;显示GVRP统计信息
[SwitchA] display gvrp status                                             ;显示GVRP的全局状态信息
[SwitchA] display gvrp statusreset garp statistics [ interface interface-list ]    ;清除GARP统计信息


11DLDP配置
[SwitchA] interface gigabitethernet 1/1/1        # 配置端口工作在强制全双工模式,速率为1000Mbits/s
[SwitchA-GigabitEthernet1/1/1] duplex full
[SwitchA-GigabitEthernet1/1/1] speed 1000
[SwitchA] dldp enable       # 全局开启DLDP
[SwitchA] dldp interval 15    # 设置发送DLDP报文的时间间隔为15秒。
[SwitchA]  dldp work-mode { enhance | normal }   # 配置DLDP协议的工作模式为加强模式。     缺省为normal
[SwitchA] dldp unidirectional-shutdown  { auto | manual }    # 配置DLDP单向链路操作模式为自动模式。  缺省为auto
[SwitchA] display dldp 1     # 查看DLDP状态。
当光纤交叉连接时,可能有两个或三个端口处于Disable状态,剩余端口处于Inactive状态。
当光纤一端连接正确,一端未连接时:
如果DLDP的工作模式为normal,则有收光的一端处于Advertisement状态,没有收光的一端处于Inactive状态。
如果DLDP的工作模式为enhance,则有收光的一端处于Disable状态,没有收光的一端处于Inactive状态。
dldp reset命令在全局下可以重置所有端口的DLDP状态,在接口下可以充值该端口的DLDP状态


12、端口隔离配置
通过端口隔离特性,用户可以将需要进行控制的端口加入到一个隔离组中,实现隔离组中的端口之间二层、三层数据的隔离,既增强了网络的安全性,也为用户
提供了灵活的组网方案。
[Sysname] interface ethernet1/0/2   # 将以太网端口Ethernet1/0/2加入隔离组。
[Sysname-Ethernet1/0/2] port isolate
[Sysname]display isolate port   # 显示隔离组中的端口信息
配置隔离组后,只有隔离组内各个端口之间的报文不能互通,隔离组内端口与隔离组外端口以及隔离组外端口之间的通信不会受到影响。
端口隔离特性与以太网端口所属的VLAN无关。
当汇聚组中的某个端口加入或离开隔离组后,本设备中同一汇聚组内的其它端口,均会自动加入或离开该隔离组。
对于既处于某个聚合组又处于某个隔离组的一组端口,其中的一个端口离开聚合组时不会影响其他端口,即其他端口仍将处于原聚合组和原隔离组中。
如果某个聚合组中的端口同时属于某个隔离组,当在系统视图下直接删除该聚合组后,该聚合组中的端口仍将处于该隔离组中。
当隔离组中的某个端口加入聚合组时,该聚合组中的所有端口,将会自动加入隔离组中。


13、端口安全配置
[Switch] port-security enable   # 启动端口安全功能
[Switch] interface Ethernet 1/0/1  # 进入以太网Ethernet1/0/1端口视图
[Switch-Ethernet1/0/1] port-security max-mac-count 80  # 设置端口允许接入的最大MAC地址数为80
[Switch-Ethernet1/0/1] port-security port-mode autolearn  # 配置端口的安全模式为autolearn
[Switch-Ethernet1/0/1] mac-address security 0001-0002-0003 vlan 1   # Host MAC地址0001-0002-0003作为Security MAC添加到VLAN 1
[Switch-Ethernet1/0/1] port-security intrusion-mode disableport-temporarily   # 设置Intrusion Protection特性被触发后,暂时关闭该端口
[Switch]port-security timer disableport 30       # 关闭时间为30秒。


14、端口绑定配置
通过端口绑定特性,网络管理员可以将用户的MAC地址和IP地址绑定到指定的端口上。进行绑定操作后,交换机只对从该端口收到的指定MAC地址和IP
址的用户发出的报文进行转发,提高了系统的安全性,增强了对网络安全的监控。
[SwitchA-Ethernet1/0/1] am user-bind mac-addr 0001-0002-0003 ip-addr 10.12.1.1   # Host 1MAC地址和IP地址绑定到Ethernet1/0/1端口。
有的交换机上绑定的配置不一样
[SwitchA] interface ethernet 1/0/2
[SwitchA-Ethernet1/0/2] user-bind ip-address 192.168.0.3 mac-address 0001-0203-0405
端口过滤配置
[SwitchA] interface ethernet1/0/1      # 配置端口Ethernet1/0/1的端口过滤功能。
[SwitchA-Ethernet1/0/1] ip check source ip-address mac-address
[SwitchA] dhcp-snooping        # 开启DHCP Snooping功能。
[SwitchA] interface ethernet1/0/2       # 设置与DHCP服务器相连的端口Ethernet1/0/2为信任端口。
[SwitchA-Ethernet1/0/2] dhcp-snooping trust
在端口Ethernet1/0/1上启用IP过滤功能,防止客户端使用伪造的不同源IP地址对服务器进行攻击


15BFD配置
Switch ASwitch BSwitch C相互可达,在Switch A上配置静态路由可以到达Switch C,并使能BFD检测功能。
# Switch A上配置静态路由,并使能BFD检测功能,通过BFD echo报文方式实现BFD功能。
<SwitchA> system-view
[SwitchA] bfd echo-source-ip 123.1.1.1
[SwitchA] interface vlan-interface 10
[SwitchA-vlan-interface10] bfd min-echo-receive-interval 300
[SwitchA-vlan-interface10] bfd detect-multiplier 7  
[SwitchA-vlan-interface10] quit
[SwitchA] ip route-static 120.1.1.1 24 10.1.1.100 bfd echo-packet
# Switch A上打开BFD功能调试信息开关。
<SwitchA> debugging bfd event
<SwitchA> debugging bfd scm
<SwitchA> terminal debugging
Switch A上可以打开BFD功能调试信息开关,断开HubSwitch B之间的链路,验证配置结果。验证结果显示,
Switch A能够快速感知Switch ASwitch B之间链路的变化。


16QinQ配置
Provider AProvider B之间通过Trunk端口连接,Provider A属于运营商网络的VLAN1000Provider B属于运营商网络的VLAN2000
Provider AProvider B之间,运营商采用其他厂商的设备,TPID值为0x8200
希望配置完成后达到下列要求:
Customer AVLAN10的报文可以和Customer BVLAN10的报文经过运营商网络的VLAN1000转发后互通;Customer AVLAN20的报文可以
Customer CVLAN20的报文经过运营商网络的VLAN2000转发后互通。
[ProviderA] interface ethernet 1/0/1   # 配置端口为Hybrid端口,且允许VLAN10VLAN20VLAN1000VLAN2000的报文通过,并且在发送时去掉外层Tag
[ProviderA-Ethernet1/0/1] port link-type hybrid
[ProviderA-Ethernet1/0/1] port hybrid vlan 10 20 1000 2000 untagged
[ProviderA-Ethernet1/0/1] qinq vid 1000     # 将来自VLAN10的报文封装VLAN ID1000的外层Tag
[ProviderA-Ethernet1/0/1-vid-1000] raw-vlan-id inbound 10
[ProviderA-Ethernet1/0/1-vid-1000] quit
[ProviderA-Ethernet1/0/1] qinq vid 2000    # 将来自VLAN20的报文封装VLAN ID2000的外层Tag
[ProviderA-Ethernet1/0/1-vid-2000] raw-vlan-id inbound 20
[ProviderA] interface ethernet 1/0/2    # 配置端口的缺省VLANVLAN1000
[ProviderA-Ethernet1/0/2] port access vlan 1000
[ProviderA-Ethernet1/0/2] qinq enable   # 配置端口的基本QinQ功能,将来自VLAN10的报文封装VLAN ID1000的外层Tag
[ProviderA] interface ethernet 1/0/3   # 配置端口为Trunk端口,且允许VLAN1000VLAN2000的报文通过。
[ProviderA-Ethernet1/0/3] port link-type trunk
[ProviderA-Ethernet1/0/3] port trunk permit vlan 1000 2000
[ProviderA-Ethernet1/0/3] qinq ethernet-type 8200   # 为与公共网络中的设备进行互通,配置端口添加外层Tag时采用的TPID值为0x8200
[ProviderB] interface ethernet 1/0/1   # 配置端口为Trunk端口,且允许VLAN1000VLAN2000的报文通过。
[ProviderB-Ethernet1/0/1] port link-type trunk
[ProviderB-Ethernet1/0/1] port trunk permit vlan 1000 2000
[ProviderB-Ethernet1/0/1] qinq ethernet-type 8200   # 为与公共网络中的设备进行互通,配置端口添加外层Tag时采用的TPID值为0x8200
[ProviderB-Ethernet1/0/1] quit
[ProviderB] interface ethernet 1/0/2   # 配置端口的缺省VLANVLAN2000
[ProviderB-Ethernet1/0/2] port access vlan 2000
[ProviderB-Ethernet1/0/2] qinq enable   # 配置端口的基本QinQ功能,将来自VLAN20的报文封装VLAN ID2000的外层Tag

http://www.cnblogs.com/jhtchina/articles/2169775.html


SSH配置:

1.添加本地用户用于ssh登录

local-user admin1

password cipher admin

authorization-attribute level 3

service-type ssh

2.添加ssh登陆终端

user-interface vty 0 4

authentication-mode scheme

protocol inbound ssh

3.开启ssh服务

ssh server enable

anzhihe安志合个人博客,版权所有丨 如未注明,均为原创 丨转载请注明转自:https://chegva.com/2344.html | ☆★★每天进步一点点,加油!★★☆

您可能还感兴趣的文章!

发表评论

电子邮件地址不会被公开。 必填项已用*标注